Fusion Reactor Not Available on 'External Server'

I have been trying to hunt down an issue that causes my Lucee application to lock up and peg the CPU.

I figured I would give Fusion Reactor a shot.

I followed the instructions here: FusionReactor - CommandBox : CLI, Package Manager, REPL & More .

I ran the following command, config set server.defaults.fusionreactor.externalServerEnable=true , registered the free trial license key, and restarted the server.

When I navigate to {URL}/fusionreactor this is what I see


What am I missing?

I was able to get access to Fuson Reactor by setting a custom port and opening up that port on my server firewall.

1 Like

Funnily enough, I just tried to use the external server last week and ran into the same issues. I swear it used to work like you first tried, but not any more. Not to worry, you can still use the external server, but it requires a small tweak, which is annoying because you need to change a setting only available to change in the FR web admin which you can’t get to!

Basically, there is a settings page inside FR for the external server. You need to go there and change the little dropdown to select “.cfm”.

Then change your URL to be this


The .cfm in the URL tricks the server into sending the request to CF instead of tryying to process it as a directory. Once you do this, you can access the external server.

So, as far as setting that, you can either try and access the FR admin over its dedicated port (a pain on Linux) or directly set that in the reactor.conf file.

Your FR config file lives here:


And you’ll need to add this line.


And if you’re wanting to automate your full server build out and manually editing files isn’t an option, CommandBox has a feature whereby you can provide a starter reactor.conf file with settings already in it.

1 Like

Hey Scott, while I realize you solved your problem with a workaround, I think you’ll find you were very close with your other approach.

TLDR; If you still have that “external web server” option enabled, change that /fusionreactor/ to /fusionreactor.cfm/findex.htm, and see if that works.

I realize you may have worked around the problem by perhaps just opening the firewall for the port of the built-in FR web server, but the purpose of that “external web server” feature (also settable in the FR UI) that means one should be able to get to FR WITHOUT that port and WITHOUT opening a firewall hole.

Instead, it’s that you have to use a URL that passes the request to CF (or Lucee) and THEN FR can pick it up, which that example above does. (I have been showing that to people for years, though I’ve not actually used that commandbox config, so I’d appreciate hearing if that works for you or other readers using it.)

To be more specific for the sake of some readers, while most might use a URL like this to access FR locally (or via another IP):

To pass that to our external web server (assuming it’s set to pass requests to yourdomain into CF or Lucee), we would change it to this:


BTW, your prior experience may indeed have been that with that FR built-in web server you could just use the url WITHOUT any file name:

Unfortunately that doesn’t work with the external web server approach. We need to change fusionreactor to fusionreactor.cfm, so that the web server gets and passes the request on to CF or Lucee, where FR (running as a java agent there) can then intercept it.

More words than some will need, yes, thus the TLDR. :slight_smile: And I should turn it into a blog post, as its news that some may appreciate hearing. That’s why I’d like to hear if it works for you. Or I may try it later on on my own. Gotta run now to help a client. Wanted to share this while I had a moment.

It won’t be obvious from the times offered here, but I was writing my reply at the same time as Brad (and I didn’t realize it), so mine is not SUPPLANTING or ignoring his. :slight_smile:

Indeed, we both had an element on the same track (the need to change the URL), but of course he adds valuable clarification on that specific issue with commandbox deployment of FR. I hope the rest of what I shared may still help some readers.

1 Like