Generic Connector Communication Error after adjusting BonCodeAJP13.settings

I’ve looked through other threads, adjusted settings but receiving an issue when we modify the ajp settings file.

Generic Connector Communication Error:
Please check and adjust your setup:
Ensure that Tomcat is running on given host and port.
If this is a timeout error consider adjusting IIS timeout by changing executionTimeout attribute in web.config (see manual). [2023-02-21 10:48:47 ]

Here is our BonCodeAJP13.settings file
The error did not exist until we added
We also adjusted the IIS Idle Timeout = 2 in the application pool from what we read online. The site is extremely fast now compared to when we did not have maxconnections, packetsize and connectiontimeout.

localhost 8020 False False False False HTTP_X_FORWARDED_FOR 1000 65536 600000 1 c:\templog 0 -1

However, we get this timeout occasionally and not sure why. There is nothing in the lucee logs, etc. Is there a mismatch between the web.config file which we also added?

						<httpRuntime executionTimeout="600" />
    <customErrors mode="Off"/>

Please include

  • your full boncode settings file
  • your full server.json file

From the looks of the message, you have boncode configured with a different port than CommandBox, or CommandBox is not running. I can’t tell either of those two things from the information you’ve provided though.