Getting started with cfcouchbase error

Trying to get started using couchbase and coldbox using cfcouchbase and have an initial issue trying to view the sample apps provided in cfcouchbase. The error appears to be in the CouchbaseClient.cfc, error is thrown on:# Invalid CFML construct found on line 1063 at column 44.# This line: var thisDocument = { id : “”, document : “”, key="", value="" };I have tried fixing this issue but I have not been able to determine the issue. I am running locally on CF9 and Windows 7.

Is your cf9 fully patched

Luis Majano
Ortus Solutions, Corp
P/F: 1-888-557-8057
Direct: (909) 248-3408

ColdBox Platform:

ContentBox Platform:
Linked In:

Social: | | |

Yes I am currently CF9.0.2.282541 and on Java 1.6.0_29.

It’s the CF9 Implicit Strict bug. Refactor that line of code so the strict is defined with empty braces and var it. Then assign the keys and values to the var.

Sorry, Implicit Struct Bug. Phone auto corrected Struct to Strict. :slight_smile:

I believe that corrects that issue but this leads to another bug in the cfcouchbase framework, unless I have done this incorrectly. Could you specify an example or provide an updated CouchbaseClient cfc? Thanks,

> this leads to another bug in the cfcouchbase framework

You’ll need to be more specific than that.

  • Error message?
  • Stack trace?
  • Cluster setup?
  • CFCouchbase configuration?
  • Sample code?
    Note, I don’t think ColdFusion 9 supports the colon to separate name/value pairs in a struct literal either. { foo : ‘bar’ } as opposed to { foo = ‘bar’ }

Pull requests would be great for any of these CF9 bugs. Even better is if you could upgrade to a newer version of CF or Railo. CF9 is going out of support very soon. Object literal bugs and old-syntax support makes it a pain for us to support.



Sorry about that Brad. I am just on my local machine setup of CF9.0.2, Couchbase on my local machine latest version. Here is the issue in the framework after changing the colons to equal signs since they are not supported in 9. Here is what I am getting now:

Yeah, I’m sure CF also doesn’t like the struct literal on that line:

options={ limit: 20, stale: ‘FALSE’ }

If it won’t take this:
options={ limit= 20, stale= ‘FALSE’ }

Then try this:
var ops = { limit= 20, stale= ‘FALSE’ };

Our docs say we’re compat with CF 9.0.2 but obviously it looks like we never tested CF9. So please let us know what you need to change and/or provide pull requests. I think you’re the only person still on CF9 who’s ever tried the CFCouchbase library.



ColdBox Platform Evangelist
Ortus Solutions, Corp

ColdBox Platform:

Thanks for the assist Brad, that first edit worked but then more errors occurred. I am still running on a CF9 environment since we have lot of “antique” apps in our system but I am going to make a move to getting up to 11 locally for testing this out. May want to change that compatibility version on the cfcouchbase page :slight_smile: