I can't open commandbox

Hi , firstly I’m new at CF but when i try to use commandbox , I get a Java error and dont know how to fix it.İts works fine with Linux but doesnt work in W10

I’ve attached a screenshot of the error message.

It would appear that Lucee didn’t install all of its extensions. Can you zip up and send me the logs inside of



Then try deleting the entire ~/.CommandBox folder and starting box again.

I attached my log files.I deleted entire .commandbox but still get the same error.Thanks for help
8 Temmuz 2020 Çarşamba 10:00:44 UTC+3 tarihinde Brad Wood yazdı:

cfml-web-logs.rar (834 Bytes)

lucee-server-logs.rar (24.8 KB)

Sorry, I don’t have a program for rar files. Can you just send a zip?

Brad Wood <bdw429s@gmail.com>, 8 Tem 2020 Çar, 10:50 tarihinde şunu yazdı:

cfml-web-logs.zip (2.13 KB)

lucee-server-logs.zip (32.8 KB)

Hmm, I can’t find anything wrong in there. Usually that error is seen when the compress extension didn’t install correctly, but the deploy log doesn’t show any issues. Are you on the latest 5.1.1 version of CommandBox?

Can you capture the output of

box -clidebug

in a text file for me?

Yes i m using latest version of the command box. Also my coworker has the same problem

CommandBox.txt (7.15 KB)

Dunno, but I’d say it’s likely due to some sort of anti virus or PC lockdown on your PCs. Unfortunately, this is difficult to debug, but the error is coming from Lucee when it is trying to compile CFML (the error doesn’t tell us which file!). I would recommend disabling any antivirus on the machine and trying a fresh install as a test. My best guess is one of the jars in Lucee is being quarantined by your antivirus-- potentially something from the compress or PDF libraries as they tend to have issues like this often. Also check the logs on any antivirus to see if it’s quarantined any files.

Thanks for your help
I disabled all windows security and deleted antivirus then try but still didnt work for me. Sorry for the trouble

Brad Wood <bdw429s@gmail.com>, 8 Tem 2020 Çar, 18:45 tarihinde şunu yazdı:

I would talk to your sys admin and ask them what sort of software on your PC might scan jar files and quarantine them. One or more of the jars in Lucee are getting blocked and until you find out what, you won’t be able to use it. Also, you said you disabled antivirus as a test, but did you also delete the CommandBox home folder to get a fresh install too?