I guess I'm lost

So it’s been a while, things have changed.

Environment is Windows 10 Pro.

1 Download and install Commandbox
2 Set up root dir
3 Install coldbox
4 start server port=80

Now I get to here and everything is fine if I’m hitting localhost or However if I hit the set up url (www.whatever.com) it does not serve.


When I try to hit the server admin I get the password set up screen. I’ve added my password.txt file everywhere. It’s still not picking it up and letting me in the admin.

So basically two questions, is there something that will prevent a standard dev commandbox generated server from serving to a public domain/url, and how do I actually set this damned password?

Thanks in advance.

When you say you “set up” a domain, what do you mean? Did you add it to your local hosts file for local development? Did you add it to public DNS somewhere? In either case, what IP address is the domain pointing to? There’s far too much missing information here to understand what you’re trying to accomplish, let along why it doesn’t work. If you are trying to make the server publicly available and you’ve pointed the host at the public IP of your server, and that public IP is either NAT’d through your firewall to your machine, and the ports are allowed, then it will work so long as you bind the CommandBox server to the public IP. Note, this is not the default behavior. By default, CommandBox will bind to localhost which will not be externally accessible. That’s just now networking works.

Regarding Lucee’s default password, this is solved very simply by using a combination of CFConfig and the dotenv module as I’ve explained here:

That said, I would recommend using an entire .cfconfig.json file for managing all of your configuration including your password and much more.

And finally, if this server is to be publicly accessible, make sure you’re on the latest 5.2 release (which just came out this week) and make sure you use the security profiles to put CommandBox in production mode and make sure the admin isn’t accessible externally for security.


So I RTFM, and some more comments. I guess it was one of those four AM kind of things. Instead of doing everything myself I moved to commandbox, used it to install cfconfig to change the password and coldbox and saw where using “start host= port=80” did everything I need.

Sorry man, thanks.

I’m glad you got it working :slight_smile: