Initial install keeps timing out

Hi all,

I wonder if anyone can help. I’m trying to install ContentBox for the first time on my local machine and not having much luck. I go to the site in the browser it loads for a good 5-6 minutes and then times out with the following error:

# The request has exceeded the allowable time limit Tag: cfdirectory

The error occurred in E:/Websites/ line 466
Called from E:/Websites/ line 294
Called from E:/Websites/ line 256
Called from E:/Websites/ line 84
Called from E:/Websites/ line 71
Called from E:/Websites/ line 78

<br>464 : <br>465 : <!--- List Handlers ---><br>__466 : <cfdirectory action="list" recurse="true" name="files" directory="" filter="*.cfc"/>__<br>467 : <br>468 : <cfscript><br>


When looking at my database it seems all the tables have been created but no data has been inserted.

If anyone has any suggestions it would be a great help as I can’t even try ContentBox on my local machine :slight_smile:

Kind regards,


Any updates?

Luis F. Majano
Ortus Solutions, Corp

ColdBox Platform:
Linked In:
IECFUG Manager:


Hi Luis,

Yeah, just tried it again on my local machine, new IIS site, new MySQL Schema, copied all the files in from a fresh download. Go to the site, still no joy just keeps timing out after several minutes.

So I tried installing on works dedicated server, within a couple of minutes it was up and running, no problems at all.

So it leads me to believe there is something wrong with my local setup. Unfortunately, I have no idea what :slight_smile:



Is the database on the same machine or on a networked server or VPS?

One of the things that I have found is that if you are using ORM, which ContentBox does the going back and forth to traverse the folders and setup, inspects the databases takes time and sometimes can and does cause this issue.

On a local development there is really only one solution, up your time out settings in the Administrator. I logged an E/R with Adobe that when ColdFusion is doing the ORM stuff that this not be included in the time out, in other words the template time out would not start to tick until the ORM had completed what it needed.

As you can guess this was a late suggestion for ColdFusion 10.

But on the same token, is why I tried hard to get the entities and services in their own directories as well, by convention. I also found that on sites that I was having this issue with if I separated these, especially the ORM the timeouts stopped.