Issue with the installation of ContentBox

When I was installing ContentBox I tried to run the web part of the install after the commndbox had finished. Using the URL fails with an error:
The target ‘interceptor-CBRequest@cbAdmin@contentbox-admin’ requested a missing dependency with a Name of ‘adminMenuService’ and DSL of ‘adminMenuService@contentbox’

This is in the current release. A similar error occurred in the ‘be’ release.

Am I using the correct URL to complete the web part of the install?


I deleted everything and ran it again and got the following error on the ‘be’ version of contentbox:
Instance not found: ‘adminMenuService@contentbox’
The instance could not be located in any declared scan location(s) (contentbox.models) or full path location or parent or children

I’m now fairly sure the web part of the installation has been completed because the database is populated with tables.

Since I have installed contentbox in a directory below root it seems most likely that whatever is initialising the required CFC has looked in the wrong places. I’ll make a brain dump as I discover what is going on.

I already updated the Application.cfc to have the location of the .env file:
this.cbEnvFile = expandPath( “/contentbox/.env” );

I’m guessing there are other places where this is needed too.


Well, I didn’t yet get anywhere with this issue, other things I had to do took up my time.

I’m back on it now and decided something might have gone wrong in the install so took the opportunity to uninstall and reinstall everything. Unfortunately, it did not fix anything. Still getting the same error.
“Instance not found: ‘adminMenuService@contentbox’”

Just checking if anyone else has solved this yet.

Current builds of Contentbox using Lucee are breaking for me. I found that it defaults to using the latest Lucee release at This is breaking. To get it to work assuming a “from scratch” install, go through the install for the Lucee engine option. After it finishes building what I see is an error about not being able to load ORM classes. I stop the server in command box with server stop. Then I edit the server.json file item cfengine to have the value of the previous stable version of Lucee: lucee@ After doing server start everything works.