JavaLoader rrror setting up new ContentBox site

I am trying to set up the latest version of ContentBox (as of today) on a CF2016 server with Windows. After manually creating the database and datasource, I start the installation process. It verifies the DSN and when I click to continue it does create the tables. The process then errors out with the following message in the coldfusion-out.log.

Jul 3, 2016 11:37:03 AM Error [ajp-nio-8016-exec-1] - Error building: jl@cbjavaloader -> wrong number of arguments with constructor arguments: {compileDirectory={W:\websites\ContentBox\coldbox\system\modules/cbjavaloadermodel/javaloader/tmp},trustedSource={false},loadPaths={[]},loadColdFusionClassPath={false},parentClassLoader={},sourceDirectories={[]}}Mapping: {PATH={/coldbox/system/modules/cbjavaloader.models.javaloader.JavaLoader},MIXINS={[]},THREADSAFE={false},DISETTERS={[]},PROVIDERMETHODS={[]},AUTOWIRE={true},SCOPE={noscope},ALIAS={[jl@cbjavaloader]},VALUE={},AUTOINIT={true},DSL={},DICONSTRUCTORARGS={[{JAVACAST={null},REF={null},SCOPE={variables},REQUIRED={true},VALUE={[]},DSL={null},TYPE={any},ARGNAME={},NAME={loadPaths}}, {JAVACAST={null},REF={null},SCOPE={variables},REQUIRED={true},VALUE={false},DSL={null},TYPE={any},ARGNAME={},NAME={loadColdFusionClassPath}}, {JAVACAST={null},REF={null},SCOPE={variables},REQUIRED={true},VALUE={},DSL={null},TYPE={any},ARGNAME={},NAME={parentClassLoader}}, {JAVACAST={null},REF={null},SCOPE={variables},REQUIRED… The specific sequence of files included or processed is: W:\websites\ContentBox\index.cfm, line: 132

I tried deleting everything, restarting CF, and re-installing but I get the same error. As mentioned, I just installed CF2016 standalone (it was running CF11 standalone) and configured things based on the CF 2016 Lockdown Guide. My other CF site, non-ContentBox, is running fine, so I can verify that CF, IIS, SQL are fine. Its possible that something in the lockdown might be conflicting so I set the CF service back to run as Administrator (as opposed to the custom CF service account), but I am seeing the same errors.

Has anyone seen this error when setting up a new installation?


Daniel Garcia