Just me? Or is there a Models caching issue?

I have an object that I absolutely know is reloading at every page
request. It reads page titles from a config file and puts them on the
page for each request, based on the handler/event.

The first time through, I added cache="true" and cachetimeout="0" to
the <cfcomponent> definition. That worked. But I knew there was a
better way, and found (in the CBCachingGuide, where else) about these
<Setting name="ModelsObjectCaching" value="true" />
<Setting name="ModelsSetterInjection" value="false" />
<Setting name="ModelsDebugMode" value="false" />
<Setting name="ModelsDICompleteUDF" value="onDIComplete" />
<Setting name="ModelsStopRecursion" value="...whatever..." />
<Setting name="ModelsExternalLocation" value="model.external" />

I removed the <cfcomponent> meta, then added these into my
coldbox.xml.cfm file, reinited the framework a few times. Now the
object is back to not caching, and the init() runs each page request.

Are the settings only an override to the object definitions? Meaning,
I still need to specify them in the <cfcomponent> tag, but whatever is
in the above settings will change the behavior? Or is this a bug I
somehow stumbled on? (There are very few bugs, so I'm more inclined
to think it's me, somehow.)

- Will B.

I did some digging. In the coldbox/system/plugins/BeanFactory.cfc,
lines 190-195, it seems to be that was I said above is true. You have
to enable the models caching via the CB config, but you also have to
have the metadata in the <cfcomponent> tag to back it up.

- WB

Yes you do.

The setting modelsobjectcaching is a master ON/OFF switch for allowing the development of time persisted model objects.

However, you still need to annotate the components to tell the factory how to persist them.