LogBox - can't seem to make the debug level work

Hi all,

I'm having trouble with the LogBox config (or rather the logbox config
struct inside coldbox.cfc). I'm running ColdBox M6 for reference.

In general the thing works fine as long as I only want logs down to
the 'info' level. When I change the "implicit level category" from
"info" to "debug" strange things happen

// change this:
info = [ "coldbox.system" ]
// to this
debug = [ "coldbox.system" ]

When I make the change above and reload the framework I get the debug
logs turning up in the trace sure enough, but the sidebar disappears
due to a javascript error 'cbox is undefined'.

I went digging to see why that might be. I ran fiddler to see what js
wasn't being called and it's this:

When I call that URL directly it works fine and gives me JS.
When it's requested as the source attribute of the script tag it
throws a CF error (in fiddler logs) which is not caught by the
'Element ROOT is undefined in a CFML structure referenced as part of
an expression. '

which appears to originate from here:
<!--- getRootLogger --->
118 : <cffunction name="getRootLogger" output="false" access="public"
returntype="coldbox.system.logging.Logger" hint="Get the root logger">
119 : <cfreturn instance.loggerRegistry["ROOT"]>
120 : </cffunction>

Removing the implicit level category altogether results in the same
If I set the implicit level category key back to 'info' all is well.

Any thoughts on why this might happen? Is the 'debug' key not valid
for that purpose? If not, how do I make the thing spit debug level

Here's my config snippet:

appenders = {
        coldboxTracer = {
        coldboxFile = {
            filePath = "logs",
            fileName = coldbox.appname,
            autoExpand = true,
            fileMaxSize = 2000,
            fileMaxArchives = 2
        db = {
          properties = {
            dsn = datasources.mydb.name,
            table = "cblog",
            autocreate = "true",
            textDBType = "text"
      // Root Logger
      root = { levelmax="debug", appenders="*" },
      // Implicit Level Categories
      info = [ "coldbox.system" ]

Do you have configautoreload setbin your coldbox config?

Yes I did have that setting. It's still set to autoreload, but cycling
the CF server seems to have brought it back from the dead for some
reason. Strange because I'm sure I already tried doing that...

incidentally it's not the first time we've had odd random things
popping up (we are very new to the framework so it's entirely likely
it's something we configured badly)

This morning my (very basic test) app was working fine, an hour or so
later (no code changes) the same page on the app was throwing this

"coldbox.system.plugins.Renderer component or interface cannot extend

again cycling the CF service fixed it.

A google search pulled up a similar issue someone had with ModelGlue
which was fixed by changing a mapping. The only two mapped references
in the application.cfc are:

<cfset this.mappings['/com'] =
<cfset COLDBOX_APP_MAPPING = "/myapp">

the second is there because the application is running in the
subfolder 'myapp' -- I presume that's correct?

site structure looks like

/ <webroot>
+ coldbox
+ myapp

I know that's horribly vague, but is there any reason you can think of
why that might occur? I'm at a loss as to where to even start tracking
it down.

Make sure cache web server paths is off in cf admin

yep it's off