Missing named argument with CF8 Coldbox 3.5 Beta

Today I tried to install coldbox 3.5 beta with no inheritance using
CF 8,0,1,195765 on IIS. I also tried loading coldbox 3.1 with no

The CFML compiler was processing:

    An expression beginning with wirebox.getBinder, on line 69, column
33.This message is usually caused by a problem in the expressions
    A script statement beginning with wirebox.getBinder on line 69,
column 33.
    A script statement beginning with { on line 68, column 98.
    A script statement beginning with if on line 68, column 25.
    A cfscript tag beginning on line 60, column 10.
    A cfscript tag beginning on line 60, column 10.

The error occurred in C:\projects\ColdboxFrameworks\system\web\services
\InterceptorService.cfc: line 69
Called from C:\projects\ColdboxFrameworks\system\web\Controller.cfc:
line 57
Called from C:\projects\ColdboxFrameworks\system\Coldbox.cfc: line 69
Called from C:\projects\test\Application.cfc: line 41

67 : // Check if base interceptor mapped, else map it
68 : if( NOT
wirebox.getBinder().mappingExists("coldbox.system.Interceptor") ){
69 :
70 : }
71 : // Register CFC Configuration Object

Luis, or Coldbox team any idea what might be happening here?

I think on CF8 you need to change:


Did john’s suggestion work? If it did, please let me know, so I can update the core

Luis, please update the core at system\web\services

line 69 from:

Thanks for you help