New ContentBox install not working

Hi all,

I’m having an issue getting a new install of ContentBox working correctly.

The error is:

An exception occurred while calling the function each.

java.lang.reflect.InaccessibleObjectException: Unable to make public sun.util.ResourceBundleEnumeration(java.util.Set,java.util.Enumeration) accessible: module java.base does not “exports sun.util” to unnamed module @69ed5ea2

The error occurred in /var/www/contentbox/modules/contentbox/modules/contentbox-deps/modules/cborm/modules/cbvalidation/modules/cbi18n/models/i18n.cfc: line 98

Called from /var/www/contentbox/Application.cfc: line 134
96 :
97 : // are we loading multiple resource bundles? If so, load them up
98 : variables.settings.resourceBundles.each( function( bundleKey, thisBundle ){
99 : variables.resourceService.loadBundle(
100 : rbFile : thisBundle,

Does anyone know what I can do to resolve this error?

I can post the full stack trace if it helps.

The system environment is:

  • Ubuntu Server 20.04
  • Coldfusion 2023 (Update 4)
  • Apache2
  • Postgresql
  • CommandBox

I installed ContentBox using CommandBox and the install wizard appears to have completed successfully.

The database is also populated with cb_ related tables.

I’d rather solve the error but if this error is only related to the i18n module, is it possible that I could exclude this module so I can move forward without it?

Any help will be greatly appreciated. Thanks

Sounds like you are on Java 17. You will need to add some exports to your JVM arguments to get Coldbox/Contentbox to work. I would suggest adding all of these here as @bdw429s has done a lot of testing to make sure the opens are there in CommandBox to run Coldbox apps and modules.

Alternately, you could switch to use Java 11 and everything should work normally then.

What version of CommandBox are you on? There should be basic Java 17 support after version 5.9 I think. java.base/sun.util is already one of the modules/packages we open automatically in the latest versions of CommandBox.

@bdw429s It looks, from the note above, that the OP is running CF standalone behind apache, and is just using CommandBox for utility.

Ahh, I didn’t catch that. Well, if they installed Adobe’s CF installer, then it should also have all the necessary opens as well. Ortus worked with Adobe’s engineers and even tested ContentBox prior to their release.

That’s a good point, because they ran the latest versions of Coldbox and ContentBox in their tests for 2023 on Java 17. Which version of Coldbox/CBORM are you running @b_w ?

Thanks for the quick response guys.

Yes. Just using CommandBox for utility.

bdw429s I installed Coldfusion using the Adobe CF 2023 installer.

The java version Coldfusion is using is 17.0.6.

I’m running CommandBox 5.9.1+00767.

If it’s relevant, I’m using the CommandBox with the JRE bundled.

@jclausen I don’t know what version of cborm I’m using.

Do I need to install the cborm module manually?

@jclausen Where/how would I add the opens you mentioned here? Is that in the JVM args in CFIDE?

Thanks in advance

@jclausen Thank you!

I added the open to the jvm.config as suggested and ContentBox is now working.


I didn’t add all of the opens listed here but now I know how to do that if any other opens are required.

Fresh Builds of Contentbox are breaking for me.

I’m have the latest Commandbox, OpenJDK11.

After doing a ContentBox installation with Lucee@5 as the engine, using contentbox-cli, everything builds normally, but the page will not load, throwing an error about not being able to initialize ORM because it can’t find the right class files.

To fix it. I stop the server and edit the server.json value for cfengine to lucee@ (it was pulling the latest registered stable tag of

After this, all works as expected.

It is 2/28/2024 and I have been trying to install ContentBox using the install instructions on Win11. I have tried Java 11 then 17, and finally tried Azul OpenJDK. I get stuck on the portion where the database tables are loaded. It fails, and using the migrate install or run-script contenbox:migrate only add those 2 tables to the database and then they fail. My suspicion is ORM. I am using commandbox with JRE included. When I open the server admin, I can validate my database is ok. It also shows ORM installed from the installer. I looked at the ORM install instructions separately, and the settings look correct in the contentbox folders. I would like to use contentbox to learn coldbox . . . any assistance to get over this issue is appreciated. I have installed it on other computers in the past without issue.