openBD and unusual error

I just dropped my application back into openbd.

I modified the AppMapping in the config file. But I get this error, is there some other setting I may have missed?

Typeinterceptors.ses.executingConfigExceptionFunction(s)onApplicationStart

±-loadColdbox

±-setupCalls

±-configLoader

±-registerInterceptors

±-registerInterceptor

±-Configure

±-throw
DetailThe file /openbd/config/routes.cfm could not be locatedTag ContextCFFUNCTION: Line=39; Column=2

±- CFSCRIPT: Line=40; Column=3

Looks like the routes.cfm file cannot be found via the cfinclude. Seems like a pathing issue. Look in your coldbox.xml for the ses interceptor and the configFile property.

No it actually the context path?

I have looked at those files, as it works in coldfusion.

It has me stumped cause i also get this error.

Oops! Exception Encountered

Application Execution Exception

Error Type: Application : errorCode.badFormat
Error Messages: Badly formatted tag
Problem occurred while parsing: Encountered invalid token after “=”

Tag Context:

ID:

CFFUNCTION

LINE:

48

Template:

C:/Applications/Tomcat 6.0/webapps/openbd/Application.cfc

ID:

CFIF

LINE:

59

Template:

C:/Applications/Tomcat 6.0/webapps/openbd/Application.cfc

ID:

CFSET

LINE:

60

Ok I am stumped, I tried dropping it into a cfusion instance and it too has a problem. It is a little more descriptive, in that it does say it can’t load the routes.cfm file. However I am at a loss to get this to work. I have looked into the documentation and I am maybe confusing myself.

So if I drop a coldbox application into a J2EE instance (CF / openbd), is it AppMapping the only thing I need to change?

Ok this is bullshit J

I have no idea what I am doing wrong, and I am getting extremely confused.

If I set the AppMapping in a cfusion instance, it will error. But if I do not add it, it will not error but will not do the SES mappings correctly.

Under openBD same error as indicated before.

Anyone?

Andrew,

Sorry, I can't help you with this. Let's wait until Luis is online...
probably in about 5 hours.

Ernst

Hi Andrew,

As we discussed on IM which will be fixed/adjusted accordingly CF
environment.

I will post more detail (WIKI Page) about J2EE setup issues/
adjustments.

Hey ColdBox Team anybody willing to work with me on J2EE issues and
testing.

Thanks
Sana

Andrew,

It is all about pathing. The routes by default point to “config/routes.cfm”. J2ee is very picky on pathing, so I would use the correct absolute pathing according to where my application lives.

AppMapping = /openbd/myApp
Routes = /openbd/myApp/config/routes.cfm

I would suggest to do the follwoing. Comment out the ses interceptor and just get the app running by adding the AppMapping to the location in your j2ee environemnt. ONce that is working, uncomment the ses and alter the pathing location of the routes.cfm.

Step by Step!!

Luis

Ok as I explained to Sana…

The problem isn’t just openBD, if I have a cfusion context instance of coldfusion 8. I get a different error, but it isn’t related to anything to do with paths. It becomes the routes, not using cgi.context_path I assume.

For example

localhost:8080/index.cfm/blog/2007/10/11/something-do-about-nothing/

Is what gets generated by Event.BuildLink, even if I have the AppMapping in config file.

Typing this manually will error as well.

localhost:8080/cfusion/index.cfm/blog/2007/10/11/something-do-about-nothing/

I think Sana understands what I mean, but Coldbox will run just not properrly when it comes to the url.

As for SES, you need to change also the link there Andrew. The baseURL, that is how the rewrite engine will link up. You are seeing that mismatch, because you need to add the context there also. You have full control on how your urls get created.

Post your coldbox.xml and your routes.cfm

luis

Tried that too, so I am at a loss.

The coldbox.xml is standard, with the ses from your examples. There is no AppMapping, is it screws up in Coldfusion running in an instance, remove it and its fine. Except the url’s.

The routes again is stock standard from your examples except for.

<cfif len(getSetting(“AppMapping”)) lte 1>

<cfset setBaseURL(“http://#cgi.HTTP_HOST#/#cgi.context_path#/#index.cfm”)>

<cfset setBaseURL(“http://#cgi.HTTP_HOST#/#cgi.context_path#/#getSetting(‘AppMapping’)#/index.cfm”)>

But it did nothing for getting the urls, de be passed properly.

Ok I am still getting nowhere with this.

Here is what I have done.

In Coldfusion 8, running under tomcat. I have setup a mapping as follows

/cfusion8 – maps to the root location that files will be served.

There is no AppMapping defined, and the application runs as expected until I hit a url mapping. The thing is I wasn’t thinking, and the error is a tomcat error as such, so it looks like my standard tomcat config is not right for tomcat. Would that be right?

Otherwise it works, just not SeS side of things. Anyone?

HTTP Status 404 - /cfusion8/index.cfm/spaces/andrew-scott/blog/

Andrew,

This came up at the Railo list a few days ago. Tomcat does not support SES urls I believe. There is something that needs to be done to Tomcat, in order for SES urls to work with it. You can search in the Railo mailing list for it, but I believe this might be the case.