RE: [coldbox:16916] Re: Coldbox 3.5.2 - models / services not found

You can turn on debug logging for coldbox which will tell you what it is injecting.

Which CFML engine are you in? I had the same issue this weekend on Railo while playing with DevBox where I used the property name=“service” inject; systax and it wouldn’t work.

I dumped out wirebox().getBinder().getMapping(‘thingBeingInjectedInto’).getObjectMetadata() and noticed that the propery name was showing as “inject”. I had to change my syntax to:
property name=‘service’ inject=true;



ColdBox Platform Evangelist
Ortus Solutions, Corp

ColdBox Platform:

HI Brad,

I’m running Railo final on OSX.

If I try: writedump(wirebox().getBinder().getMapping(‘PartnerService’).getObjectMetadata());abort;

I get: Error Type: expression : 0
Error Messages: No matching Method/Function for WIREBOX()

I tried changing to: property name=“PartnerService” inject=true;

and I get the following error:

Error Type: Builder.DSLDependencyNotFoundException : [N/A]
Error Messages: The DSL Definition {REF={null}, SCOPE={variables}, DSL={id:true}, ARGNAME={}, NAME={PartnerService}, VALUE={null}, JAVACAST={null}, REQUIRED={false}} did not produce any resulting dependency
The target requesting the dependency is: ‘handlers.General’

The above occurred when I tried doing a reinit