Relax: Variable BINDER is undefined.

Hello Guys,

I\ve just dropped the relax module into my app, when trying to init the app I get the following exception:

Any ideas on what may be causing this?

It seems that ‘binder’ isn’t defined anywhere inside the config cfc so I assume that it’s meant to be injected by the framework and isn’t?



Yea very weird. If that didn’t work no modules would work. Verify version of coldbox you on?

Hi Luis,

I have my own custom module that’s working just fine.

I’m running on ColdBox 3.1 by the looks of things. ColdBox 3.1.0 NEAR-JAMES 4:8

Should I be doing anything other than just dropping the Relax folder into /modules ?


That’s it. Can you verify you are using wirebox in your config?

Assuming that Wirebox is the IoC that comes bundled with ColdBox then yes I am :slight_smile:


Then I am baffled at why it does not recognize

Hi Luis,

I’m back trying to tackle this problem again today as I really need to get up and running with Relax.

I’m still getting this ‘binder’ is undefined error.

I downloaded a fresh copy of ColdBox 3.1, just to be sure I hadn’t broken my previous copy, and it’s still throwing the same error.


Ok Will investigate. Do you have this in your parent config

Wirebox = {
Enabled = true

Hi Luis,

Great, so it seems we’re making a little progress. I did not have that setting in my config, adding it in means the app now inits without an error. However:

  1. When going to the entry point for relax ?event=relax:home.index I get a new exception.

Application Execution ExceptionError Type: Controller.SettingNotFoundException : [N/A]

Error Messages: The setting htmlBaseURL does not exist.
FWSetting flag is false

  1. I don’t understand if Wirebox wasn’t enabled before, why dependancy injection within the app appears to have been working fine :-s are they two separate things?

Thanks for your help Luis.


in 3.1 you had to turn wirebox on explicitly, else it used the compatibly bean factory which has been removed in 3.5

As for the 1 error, that means that SES is not enabled. As relax relies on SES being enabled.

Luis F. Majano
Ortus Solutions, Corp

ColdBox Platform:
Linked In:
IECFUG Manager:


Thanks for the explanation Luis, I shall look at getting SES enabled today.

Thanks for your help.