SES - cannot remove index.cfm

Hi everyone,

i guess i’m missing some little detail but i can’t find out how to remove the index.cfm from my urls anymore
I made another installation a few months ago that worked right and now it fails…

So for now i have my coldbox.cfc

interceptors = [
{class=“coldbox.system.interceptors.SES”, properties={ configFile = “config/routes.cfm” }}

in my routes.cfm i have

// Base URL
if( len(getSetting(‘AppMapping’) ) lte 1){

// Your Application Routes

(this last one i also tried without index.cfm in the base url but with no luck)

and i’m using the web.config bundled with coldbox saying

so when i write

http://localhost/index.cfm?event=aaa.bbb =>it works

http://localhost/index.cfm/aaa/bbb =>it works

http://localhost/aaa/bbb =>it fails by redirecting to the main.index even

any idea what else i should check?

thanks for any help

The last step needs a mod rewrite to be switched on in your Application server.

Sorry i didn’t mention it but i installed IIS URL rewrite 2.0 on IIS 7
And it works cause http://localhost/?event=aaa.bbb works
but http://localhost/aaa/bbb redirects to main.index event

could it be that it doesn’t find my routes.cfm file at all?

Well, what steps have you taken to debug the issue?

If the web server rewrites and SES interceptor are enabled like you say, it should be find your event. Try dumping out the CGI scope in your application.cfc’s onRequestStart to see what is being passed from the web server. We can make guesses, but you’re the only person in the position to actually debug it.



ColdBox Platform Evangelist
Ortus Solutions, Corp

ColdBox Platform:

ok thanks …empty path_info…i guess i have to install coldfusion 10 update to solve that…
as far as i remember update 1 solved this issue…but i can’t find update prior to 8…so i installed it but it didn’t solve the problem with that update not with update 13
does someone know which update i have to install?

Thanks again

Make sure you uninstall and reinstall your IIS connectors. That has caused this sort of issue many times.



ColdBox Platform Evangelist
Ortus Solutions, Corp

ColdBox Platform:

nevermind i forgot to update iis connector…it works now

Thanks everyone

the worst thing is that i encounter the same issue at least once every year and each time i lose half a day to solve it… :frowning: silly me

No, Update 1 does not solve the fact that every update you MUST reinstall the connectors. Which is what you will need to do if you’re having the cgi scope issue.

So when you update and it clearly states in the update screen, you need to do that, you thought you wouldn’t?

let’s say i just can’t read :wink: