Setting up models in my contentbox module

I am still having an issue with registering the models for my contentbox add on.

I read in the wirebox documentation that the models have to be registered with wirebox and I have tried adding the code to do that in several different locations. Unfortunately none of them appear to work.

I’m using the following code in the ModuleConfig.cfc
binder.mapDirectory( packagePath = “#moduleMapping#.models”, namespace = “@cbFormBuilder” );

I have tried putting this in the configure() method and in the onLoad() and onActivate() methods but none of these seem to work.

By work I mean that after activating the new module in the contentbox admin the models are not found when I try to use them to create a VirtualEntity using the ORM. It sees all the contentbox entities but none of the entities I have tried to register.

Can anyone point me at the correct place to do that?

In case anyone is having this issue the fix is here:

1 Like

Great work on this, Kevin! You have decreased the pain level for all future Contentbox installations. :smiley:

1 Like