still not working after refactor on shared hosting - coldboxproxy?


I have had a flash application with a coldbox backend running on a
shared host for a while now but now it is failing trying to reach
eventHandler.CFC in someone else's sandbox?

I refactored as per the coldbox guide and do not reference coldbox
anywhere, I have a new CF mapping for the new path to coldbox..

Client going crazy, any help appreciated.

flash UI

HTML UI to see error




Coldbox requires "AppMapping" for Flex/AIR remoting

<Setting name="AppMapping" value="/MyApp"/>

this.mappings['/MyApp'] =

So this ensure that I have correct path for components and others like
cfinclude etc



Hi Sana

Thanks for responding so quickly. I had done that already and really
think that I have tried everything from the guides!

When the application it runs the new refactored code fine, as I can
see in the CF Error the correct path to the coldbox I am using.

here is a snapshot of the error:

Date/Time 04-Mar-11 12:07 AM
Stack Trace access denied
( D:\Inetpub\spiderwebstrategies\VerballyNoted
\coldbox\system\EventHandler.cfc execute) at
\HandlerService.cfc:40) at
\HandlerService.cfc:97) at
391) at cfcoldbox2ecfc7868905$funcONSESSIONSTART.runFunction(D:\Inetpub
268) at cfApplication2ecfc102852493$funcONSESSIONSTART.runFunction(D:
\Inetpub\DomainID205115\Application.cfc:76) access denied
( D:\Inetpub\spiderwebstrategies\VerballyNoted
\coldbox\system\EventHandler.cfc execute)

I really need help with this as client going mental and I have to have
it running in the next few days :slight_smile: anyone feeling generous.

Thanks all


That looks like a sandboxing issue.

You’re trying to access a file somewhere that the sandbox isn’t allowed.

I’d work with the shared host to work out which directories are allowed for CF to access.


HI Mark

Thanks for the speedy response, yes that's right it seems to execute
through coldbox correctly from the new refactoured coldbox folder
which I have now put into frameworks/coldbox_2_6_4/coldbox but when
the it still try's to read out of the other sandbox..

Do you know of any simple tests I can do to check all my paths etc?



I think you misunderstood what Mark was saying. The stack trace you posted indicates that it is not a path issue with ColdBox. Rather, it appears that you are on a shared server and the host has created security sandboxes. The sandbox that you are in does not have permission to read the file that it is trying to read.

In other words, you will likely have to talk to your host to see if they can give your application access to the directory/file(s) in question.


Hi Thanks for your response

I fixed the issue, when I refactored by find and replace rather than
ANT, i forgot to change my handler files too! so they were extending
coldbox.system still, and hence trying to get to the CFC files within
another hosting clients sandbox that was using a CF mapping of

Thanks for everyones help