TestBox weirdness between machines

I am hoping that perhaps something " just pops into mind" for someone to help me out.

My local machine and the staging server are identical - in terms of lucee version / testbox version / application code.

The cf admin mappings are identical - albeit with different “endpoint paths”…
(but a cfm in /myMapping - in both environments runs fine.)

In the staging server if I run the tests/runner.cfm IN the testbox directory - I get the expected result. (results of tests)

When I run a .htm or .cfm in my approot/tests/ directory I get the expected results.

In approot/tests I have a CFM that I call with the following contents.

variables.testRunner = new testbox.system.TestBox(directory={"mapping"="tests", "recurse"=true});
writeOutput("#variables.testRunner.run()#<br />");

On my local machine the page loads / displays results in less than 2 seconds.
(The request timeout in local and staging is set in minutes)

Yet when I call the page on the staging server : it times out and I get a a gateway 504 error message.

Any ideas?
And of course - thanks.

Interestingly - I have set the nginx request timeout to 5 minutes.
(And reloaded and restarted the nginx service)
Same with the Lucee timeout. (5 minutes)
But the page still spews out a 504 after 1 minute.

And the rest of the app/site is working as expected.