Trying to install contentbox

I am running a commandbox setup on my desktop. I am using the box.exe for the shell. I have created a directory and installed contentbox through the command line. I created a datasource and followed the instructions. However it is not working. I get to this page → http://localhost/CB/index.cfm/cbInstaller and it displays Not Found…I know it is do some stuff as I have tables in my db but I can not get past that page to do anything else. I have searched and not found any information on this issue. I have even tried downloading contentbox and unzipping to the directory and still get the same results. I have used datasources named contentbox and cb and still no luck. What am I doing wrong?

Hello Mark,

I assume this is because you have the app in a subfolder. The default SES servlet mapping is for /index.cfm/* which does not work in a sub folder. On a regular server, you would need to edit your web.xml. For CommandBox though, simply start the web server from the actual web root folder. So, “cd” into your “CB” folder and run “start” from there.



ColdBox Platform Evangelist
Ortus Solutions, Corp

ColdBox Platform:

Thanks it is up and working now.