Using RailoProvider on ACF9.01 std


I've seen this before on a production server (can't replicate on dev
server) and it's just happened again. I get an error about the wrong
number of arguments for cacheGetAllIds() and cacheGet() methods. When
I look at the stacktrace I see that it's in the RailoProvider.cfc.

I edited those function calls to match the Adobe spec and it's all
fine now. I would have done some better debugging if it wasn't on a
live site!


- John

Are you using the Railo Provider? Or, is the real issue here that it was instantiated at all?

I had this happen to me before too. Are you using the CF9 ORM? I am and Luis told me to set skipCFCWithError to true. That fixed it for me.


Thanks Dusting, yes i’m using orm, i’ll have to try that.

Aaron, I assume that coldbox detects engine and loads the right provider. I’m not instantiating it in my code.

– sent by a little green robot


Thats part of what was confusing me. You’re subject said “Railo” on ACF901.


Wanted to chime in on this as well. I had the exact same problem when
I started using ORM stuffs with rc2, butchered the RalioProvider.cfc
to conform to CF9 methods 'fixed it'

OK, I'm glad it's not just me then. I'll provide a bit more info to
hopefully give some pointers....

- I'm using ORM
- the this.ormsettings.cfclocation to points to my model directory
(and sub directories).
- I'm using this.ormsettings.eventhandling = true;
- with this.ormsettings.eventhandler set to "model.aop.ORMEventHandler";
- model.aop.ORMEventHandler extends coldbox.system.orm.hibernate.EventHandler
- in my config I have handlerCaching and eventCaching flags set to true

I was running on RC2, but tried the lastest from GitHub and had the same issue.

- John