Weird Bug with Files from GitHub Causing CommandBox to be Unable to Start

OS: Ubuntu 22.04 | CommandBox Version: 5.5.2 | Lucee Engine: 5.3.9+141

Having a really strange issue. I’ve installed CommandBox from scratch and am using the Lucee engine. Everything works fine until it’s time to pull my web files from GitHub. Initially, all the files are served properly, but upon restarting the service, it is unable to start. I’ve tried a couple of things (changing user/group ownership, copying the files manually, even changing file permissions for the folder and everything inside) but it fails to start every single time.

I’m able to bring it up by deleting the web root folder and recreating it. I’m also able to run files that I create locally with echo/touch no problem. Kind of at a loss here as to where to go from here.

WebRoot has about 1550 files in it. Here’s the debug console from startup:

[DEBUG] Runwar: Server Mode: war
[INFO ] Runwar: ******************************************************************************
[INFO ] Runwar: Starting RunWAR 4.7.7
[DEBUG] Runwar: HOST to be bound:
[DEBUG] Runwar: Requisitioning ports (http) (stop) (https)
[INFO ] Runwar: Binding HTTP on
[INFO ] Runwar: Enabling HTTP/2
[INFO ] Runwar: Binding SSL on
[DEBUG] Runwar: Creating SSL context from cert: [/etc/ssl/certs/website.crt]  key: [/etc/ssl/private/website.key]
[DEBUG] Runwar: Using default store passphrase of 'password'
[DEBUG] Runwar: One certificate, no chain:
[DEBUG] Runwar:    X.509  certificate, public key [ RSA ] CN=*.website
[DEBUG] Runwar: Adding key to store - alias:[serverkey]  type:[RSA PKCS#8]  passphrase:[********]  certs in chain:[1]
[DEBUG] Runwar: UsingTSL
[DEBUG] Runwar: host:
[DEBUG] Runwar: Creating SNI SSL context for hosts: []
[DEBUG] Runwar: ajpEnable:false
[DEBUG] Runwar: WAR root:/opt/www/web
[DEBUG] Runwar: background:false
[DEBUG] Runwar: Adding additional lib dir of: /root/.CommandBox/server/serverHome/lucee-
[DEBUG] Runwar: WEB-INF classes directory (/root/.CommandBox/server/serverHome/lucee- does not exist
[DEBUG] Runwar: Initializing classloader with 1 jar(s)
[DEBUG] Runwar: Server Mode: war
[INFO ] Runwar: Servlet Context: /
[INFO ] Runwar: Log Directory: /root/.CommandBox/server/serverHome/lucee-
[INFO ] Runwar: ******************************************************************************
[DEBUG] Runwar: Added shutdown hook
[DEBUG] Runwar: Transfer Min Size: 10485760
[DEBUG] Runwar: XNIO-Option CORK:true
[DEBUG] Runwar: XNIO-Option TCP_NODELAY:true
[DEBUG] Runwar: URL rewriting is disabled
[DEBUG] Runwar: enabling path_info filter
[DEBUG] Runwar: File cache is disabled
[DEBUG] Runwar: Extensions allowed by the default servlet for static files: 3gp,3gpp,7z,ai,aif,aiff,asf,asx,atom,au,avi,bin,bmp,btm,cco,crt,css,csv,deb,der,dmg,doc,docx,eot,eps,flv,font,gif,hqx,htc,htm,html,ico,img,ini,iso,jad,jng,jnlp,jpeg,jpg,js,json,kar,kml,kmz,m3u8,m4a,m4v,map,mid,midi,mml,mng,mov,mp3,mp4,mpeg,mpeg4,mpg,msi,msm,msp,ogg,otf,pdb,pdf,pem,pl,pm,png,ppt,pptx,prc,ps,psd,ra,rar,rpm,rss,rtf,run,sea,shtml,sit,svg,svgz,swf,tar,tcl,tif,tiff,tk,ts,ttf,txt,wav,wbmp,webm,webp,wmf,wml,wmlc,wmv,woff,woff2,xhtml,xls,xlsx,xml,xpi,xspf,zip,aifc,aac,apk,bak,bk,bz2,cdr,cmx,dat,dtd,eml,fla,gz,gzip,ipa,ia,indd,hey,lz,maf,markdown,md,mkv,mp1,mp2,mpe,odt,ott,odg,odf,ots,pps,pot,pmd,pub,raw,sdd,tsv,xcf,yml,yaml,handlebars,hbs
[DEBUG] Runwar: No welcome pages set yet, so adding defaults to deployment manager.
[DEBUG] Runwar: welcome pages in deployment manager: [index.cfm, index.cfml, default.cfm, index.html, index.htm, default.html, default.htm]
[DEBUG] Runwar: found WEB-INF: '/root/.CommandBox/server/serverHome/lucee-'
[INFO ] Runwar: Parsing '/root/.CommandBox/server/serverHome/lucee-'
[DEBUG] Runwar: Added websocket context
[INFO ] Runwar: Creating deployment [default] in /opt/www/web
[DEBUG] Runwar: Initialized CACHED MappedResourceManager - base: /opt/www/web, web-inf: /root/.CommandBox/server/serverHome/lucee-, aliases: {}
[DEBUG] Runwar: ResourceManager Cache total size: 50 MB
[DEBUG] Runwar: ResourceManager Cache max file size: 50 KB

I didn’t mean to cross post THIS question. I meant future questions :wink: I’ve already provided you with what I think the answer is here in your original SO post:

Sorry, thank you! I just tried your solution and it worked instantly.

1 Like