Weirdness, Weirdness, Weirdness

I have two sites on the same VPS. I’m running BD 7 and have Cache per website checked. Both websites are running ColdBox 2.5.1.

In the first website, , the request context is not being passed to the views. It keeps throwing an error saying a query is not available that in actuality is defined in the controller. FYI, I have SES disabled (no intereceptor defined in the CB config and setEnable() as false in the routes config).

On the second website,, the main website is working fine it appears. However, when I go to the embedded administration app I get odd behavior. When I try to login the doLogin action never completes (or so it appears) and the page remains blank and is never forwarded to the next route. If I try to go directly to another action the page is blank. On this site I do have SES enabled.

Can any sense be made of this?


To follow up, both of these sites work perfectly fine on my local development where I am running CF8. This morning I checked on the first site and without any intervention all of a sudden it now works. However, the second site still gives me a blank screen every time I try to login or go directly to a page in my administration. Check it out for yourself using any credentials you would like:

Could these oddities be due to the fact that I’m running BD7 on my production server? Is it just setNextRoute() that is not working on BD7 or is it the entire embedded app approach that is not working? I’m trying to test and test and test. If anyone here can think of anything to help me test I would appreciate it.


Hi Aaron,

Can you see debugging

check error logs and I hope /admin/ is physical folder then put .htaccess in that as well …

I am out of ideas now… lol


Hey Sana,

Yes, admin is a physical directory and I do have a .htaccess file there. I’m checking the logs but there are empty (besides the main initialization). I’m even trying to write logs when before the login page is displayed but my log file is still empty.

I’m at a bit of a loss for this one as well.


Hmm, in the routes config I changed setUniqueURLs() to true and now the login page is blank. There is definitely something going on with the redirect on my server. Any ideas, I don’t know much about redirects?


Hey Aaron,

You don’t need setUniqueURLs(true) for your admin section, it should be setUniqueURLs(false).

I guess something is not correct in your routes.cfm

<cfset setBaseURL(“YOUR-DOMINS/admin/”)>

I hope this will help you when you set the uniqueURLs


This is what I have for setBaseURL():

<cfset setBaseURL(“http://#cgi.HTTP_HOST#/admin”)>

I only changed setUniqueURLS() to true for testing. I changed it back right away.


Yes, unique URL’s means, that no event variable will ever be passed via form or URL, because basically you are going via routest. I checked your form submit and it submits to /index.cfm?event=

This will not work under unique URL’s. You have to submit to the actual “COURSE”.

SES is indeed tricky. The problem you mentioned when it suddenly worked again, might be a memory issue. Maybe something was cached, or the cfclasses where being reloaded. Try cleaning your cfstubs and cfclasses inside of your cf web-inf folder.

As for odd behavior on setNextRoute, its odd, because, it basically is just a cflocation. I would try setting unique url’s off for the admin, and not use ses and see if it works. Or set it disabled. Then if all works, and you move to ses, (no unique urls), then you have to make some modifications to links and form submits.

Ok, I get the blank page. It seems something wrong with the form submit. Also, when I change the url to:

It works. So something related to the .htaccess for some reason. Also, make sure your form submits, are to the routes not the the index.cfm?event=


Sana and I were testing all kinds of things and the last thing we tried was to test with index.cfm?event= and that is why the form is currently setup that way. It is odd. Even though the embedded app is all setup for SES and has the same settings (besides sesBaseURL including the path to the admin directory) as the root web app SES is not working and index.cfm is. I don’t get it.


Earlier the website was working just fine but when I returned just now the site gives me an error saying that a certain query does not exist. However, that query is defined in the handler and the names and everything match. This code was working up until I created a second VHost on the server, uploaded the second site and then set cashing to cache per website in the BD admin. Because it was not working, I then upgraded the coldbox installation on that site to 2.5.1 and disabled all the SES features.


OK. I don’t like it but I have set the urls in the embedded admin app to use the long version. All works for that now. But it is odd, the site works fine on my development machine but not on production. Interesting still, the long url works on my local even though the short version also works with the same settings. What I don’t like about it the most is that I have to write setNextRoute() like setNextRoute(" index.cfm/handler/action") which is not syntactic sugar.

Now if only I can get my other website up and running again (; ses is not enabled but I still keep getting an error saying a query is non-existent in the request collection although it is placed in the request collection in the handler).