Where should I put the /lucee-server/context/password.txt file?

On Lucee 5.3.5+92 I get this message when attempting to access the server admin.

2020-04-04_1330 - Lucee Server Password Config.png

The “import file” button does not open a file selection dialog, so I’m assuming that it’s looking for the specific password.txt file at a specific location, which should be /lucee-server/context/password.txt.

In my mind, the “root Lucee server directory” could be referring to one of two places…

  1. The WebRoot

  2. The Server Home

2020-04-04_1339 WebRoot.png

2020-04-04_1339 Server Home.png

I’ve tried creating a /context/password.txt file within both locations and clicking "import file" but neither worked. What am I not getting here?

I had this problem too…i solved it by using cfconfig. For example.

2020-04-04_1330 - Lucee Server Password Config.png

2020-04-04_1339 WebRoot.png

2020-04-04_1339 Server Home.png

I thought I had it figured out when I found Resetting Lost Admin Password. I’m on Mac, but the path for linux didn’t correlate to anything useful on my system. But using the Windows path correlated fine. Starting from the “Server Home” I went up to ".CommandBox" then drilled down to…

.CommandBox/engine/cfml/server/lucee-server/context/ where I placed the password.txt file and tried again confident I had the right location. I didn’t. This did not work either.

Thanks Adrian… I ran this command…

config set adminPassword=commandbox to=.config.json

then restarted, but still found no love. I also tried it without the “to” option.

Thats a bummer, maybe you don’t have cfconfig installed.

box install commandbox-cfconfig

then reboot

Maybe that wasn’t a good answer. I’m using commandbox v4.8 and i didn’t need to install cfconfig.

So i thought maybe it’s the lucee version. I started up a 5.3.5.+92 and used cfconfig to set the password.
I’m on a mac. It worked for me.

So my next guess would be maybe you’re on a commandbox version that doesn’t know how to handle this new lucee password policy.

I’m using CommandBox version 5.0.1+00137 (latest…I just upgraded)

Your answer was perfect actually. I installed cfconfig as suggested (I didn’t know I needed to before and had not heard of this extension) then ran the command you suggested, restarted, and it worked perfectly! Thanks for your help.

Another thing. your server context should look something like this

/Users/[account name]/.CommandBox/server/D0FC5D558363E92D41C47ED1B68E2CA6-test/lucee-5.3.5…92/web-inf/lucee-server/context

Run this command to find yours and then cd into the web-inf for the context.

server info property=serverHomeDirectory

Once you have it, you just do something like this

cd /Users/[account name]/.CommandBox/server/D0FC5D558363E92D41C47ED1B68E2CA6-test/lucee-5.3.5…92/Web-inf/lucee-server/context
echo ‘test’ > password.txt

and now your password would be test. But yes, commandbox makes it much easier.

That’s awesome it worked. I’ll walk tall today for helping at least one person :wink:

Just for future reference, in your CommandBox properties folder (which might be in ~/.commandbox) there is a folder called “server” which has all the servers that you launch with CB in it. If you open the one with the server you want you can put the password.txt file in “/WEB-INF/lucee-server/context/”

The CFConfig route works as well obviously.


Ah, thanks Dan! That’s what I was looking for, but I’m grateful that Adrian’s solution opened my eyes up to the cfconfig extension because that’s super helpful in a more general sense too! I’m currently (and happily) running down that bunny trail.