You Asked for Port [xxxxx] in Your server.json but It’s Already in Use

This is strange. I have a CommandBox site that I have used for years, but for some reason today I am getting the following error:

You asked for port [60830] in your server.json but it’s already in use.
Please choose another or use netstat to find out what process is using the port already.

I checked netstat, and even the GUI tool tcpview, and don’t see anything using port 60830.

Normally I would just change the port in server.json, but this is a REST API site that I have a few other Commandbox instances configured to access it which depend on the port. Is there another workaround for this error?

Here’s what I tried so far:
server start --force
server forget and server start

Neither attempt worked.


server info --verbose

to see if there’s more info. Sometimes I’ve had issues with the Java networking stack that’s required an OS restart to clear.

1 Like

Interestingly enough, disconnecting from my VPN did the trick and released the port. Thanks for the reply, Brad! Happy holidays. :slight_smile:

1 Like